Windows 8 Update To 8.1

 
#1

This is a tutorial and update with my windows 8 updating to windows 8.1 " free update" that takes a long time, and EZ Builder.
I could not connect to EZ Builder with my old parameters. I had to do a "refresh list" of com ports and "change" from com port 5 to port 3 and was able to connect. Your com ports may vary. try the lower one of your refreshed list.
After that my project ran successfully.
Maybe this will help someone else performing the windows update.
Thank You,
Steve S

#2

The com port issue was discovered in an earlier post for folks going to 8.1. We were used to always using the lower numbered bluetooth com port to connected to the EZ-B but after the Windows update the higher numbered com port is used.

#3

Is it always the higher number? I assume Windows 8.1 just mixes them all around a bit but in no particular order after the update. I've not updated to 8.1 yet (I don't use my Win 8 laptop often) but knowing Microsoft I'd say that it may not always be the higher of the two, it could just be any of them.

Would be good to hear what others say who have upgraded to 8.1 too.

#4

Thank You Robot Doc,
After the update I had to use the lower com port from the refreshed list.
I just checked again, it is com port 3 that works.
That is what worked for me to connect without pairing again. Maybe other PCs are different?
Steve S

#5

Here is the original post where there was a discussion about the bluetooth com port issue with Win 8.1

#6

Thank You,
Here is my PC list after updating from windows 8 to 8.1.
Com port 3 works on my PC, 4 does not.
This list was after I resaved my file showing the default com port 3 appearing.

User-inserted image

#7

So it appears that there is no set rule to which com port will be recognized by EZ-B(3) after updating to Win 8.1. If your connection does not work when you try to connect, just try another port until you are successful.

#8

At first my laptop running Win 8.1 would only connect to the higher COM port but recently it now connects to the lower. I don't know if it had to do with an update in Windows or an update to EZB software that fixed it back to the lower.
As an experiment I would suggest updating to latest software then deleting and re-adding the ezb and see if it changed.

PS. If it works on one of the two, then keep using it for now.

#9

I have EZ builder on a few different Win 7 machines and its a different number on each one. I just figured it was due to devices previously connected.

#10

Antron007 You are correct. Each Windows PC has a memory bitmap area that keeps track of what ports are used or available to assign a com port for Bluetooth USB use. Each PC may have different ports assigned for different applications that have been installed.