Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Disgard Incoming Buffer (this Should Never Happen)

Assistance Requested

Help familyman with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

familyman claims to have checked these sources:
 
#1

I am trying to use my ps3 controller to control my robot. I can get the joystick#1 to move forward/backward and left/right. But when I try to add some buttons everything goes nuts. This what I have set up.
Robot dragon..
Joystick#1 up/down controls head up/down.
Joystick#1 left/right controls head left/right

Then I wanted two buttons to control left and right wings.
I tried the L1 and L2 buttons and then I tried the Square and Circle buttons. They both worked seperatly, but then when I try to move the head and press the buttons all the servos start acting crazy and I get the error message 'Disgard incoming buffer (This should never happen)' and then I lose connection with the EZ board. Any help?

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Have you tried upgrading? That error message is from a very old version. Usually when that message appears it is due to a loss of power. Or, it is from radio interference with the EZ-B. Those are the only two reasons for that message.

I would suggest upgrading to the most recent EZ-Builder first.

#3

Thanks man!,
While downloading the newer version, I did some reading through the boards and was wondering if it was a power problem.
I have only had the EZB for a few months and figured I had the updated version of the software. I downloaded a slightly newer one. The same thing happens but this time instead of the previous error message I got a report saying something along the lines of the EZB needs more power. I really don't want to have to keep replacing 6 AA's every day, Can you or someone else suggest a power pack?. I am not very electrically minded and do not want to burn out the board. I will be doing a search as I am sure this has been answered before, but in case I can't find it I would be very grateful if someone could tell me what voltage the board runs off. I am sure I have a power supply somewhere that will work. Thanks.

#4

The EZ-B can run on anything from 5v to 17v, most common voltages are 6v, 7.4v and 12v.

#5

Ooops, didn't see this post, but I added a bit of info to @familyman's other post
here.

#6

I use a 7.2v 2800mah battery....tons of power

also just noticed the new EZB used a Deans power connector.....that's awesome.

#7

And there's a LiPo battery in the store too Smile

#8

@ Familyman - Awesome , looks like you got some great answers. Do you mind marking this thread as answered? This way we can clean out some of the unanswered threads. Thanks in advance! - Josh

#9

sorry man, I totally forgot to do that. Doing it now.