Award
Congratulations Niek, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

"camera Controlcommand Error" With The Camerarecordstart Command

Assistance Requested

Help fredebec with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

fredebec claims to have checked these sources:
 
#1

Hi, since a recent update (I don't know which one exactly), the ControlCommand "CameraRecordStart" returns a Camera ControlCommand Error and interrupts the script. The "CameraRecordStop" command returns no error.

All I can tell is that this command worked with the 2013.07.03.00 release... It is probably a small bug on the road to Revolution Winky

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Are you sure you used quotation marks around "Camera"? I tried

Code:

ControlCommand("Camera", CameraRecordStart)

and had no problems.

#3

I tried last night and had the same problem on an older version (a couple of updates behind at most).

When I tried I used the Click & Paste to add it to the script from the controls part of the EZ-Script dialogue so it should have been 100% correct, I honestly don't know if it had quotes or not though.

I'll have another go later with the latest version.

#4

@Niek, like Rich did, I have used Click & Paste from the Controls. I have verified and the quotation marks are present. Moreover, the same script worked well with the 2013.07.03.00 release, so it is a recent issue...
Are you using the last version as well ?

#5

@fredebec, I just updated to the latest (2013.08.19.00) and it worked fine.

Have you tried uninstalling and reinstalling EZ-Builder?

#6

@fredebec
I used the latest version and clicked under the ControlCommand tab. It should be fixed in the latest version Winky

#7

Ok, I found the problem !

First I tried to reinstall EZ-Builder, with no success... So, I tried to create a new project (in spite of creating a new script in my existing project) and then in worked !
At first, I didn't see any difference between the two projects, but there was:

When you create a new project and add the Camera, in the "Media" part of the Camera preferences, there is automatically "www.ez-robot.com" with quotation marks entered in the "Title Text" field (see the screenshot)

User-inserted image

But in the previous version of EZ-Builder I used, www.ez-robot.com was automatically entered without the quotation marks... and the new version don't like it !

So, I just had to add quotations marks in the Title Text field of my old project, and voilà, everything works again.

Thanks @Niek and @Rich for your help
(PS: As it was a quotation marks issue, after all, I think Niek deserves the credit of the "resolved topic" Winky )

#8

Ah, I remember another topic which brought that up now you've mentioned it. I didn't even think to check in there to be honest, now I know for next time it happens (if there is a next time).

#9

@fredebec well that's a sneaky bug! Glad you figured out a solution.

#10

The exact error message you received would tell you of the error Smile

It's always best to screenshot or write down the exact error when asking for help.

But, glad you figured it out Smile