Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Assistance Requested

Help fredebec with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

fredebec claims to have checked these sources:
 
#1

Hi,

I try to use some twitter functionalities in EZ-Builder but I encounter some difficulties.

I have configured my account in Option/Twitter in EZ-Builder with no problem, but after that nothing works, neither the Twitter Recognition, nor the Tweet script.
Each time I have an error message as you can see in the capture (1 is for Twitter Recognition ; 2 is for the script)

User-inserted image

So, I need some help... Thanks

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I haven't used Twitter for a while since Melvin is undergoing some big changes but a quick test just threw back

Quote:

Error on line 1: Exception of type 'System.Exception' was thrown.

when I tried to use the code

Code:

Tweet("Test")



You aren't alone on this issue. I'll have a better look into it if I can get Melvin running as I know his camera tweet script worked previously.

Update: Melvin's twitter posting scripts throw the same error and do not post to twitter. They have been working previously (June 6th being the last time it successfully posted to twitter but that may have been the last time I tried it) so I can only assume something to do with either twitter itself or the twitter script commands no longer works as it should.

Can others check this out please? Just set up twitter (if it isn't already linked) and add a script with

Code:

Tweet("test")


Hopefully that'll help us solve this problem.

#3

@Rich, Thanks for your help. Lets see if others have the same issue...

In the meantime, is there another simple way in EZ-Builder to send a message (an alert) through Internet when an event takes place?

#4

Update: Tweet() throws the same errors in the previous version (I haven't updated the laptop yet). I will try my office PC shortly and see if it throws the error on that one (not updated for a while either).

Update: version 2012.06.06.00 throws the error too.

#5

I'm looking into it now. Twitter keeps changing their API! This has happened a few times in the past... Silly twitter

#6

Thanks @DJ for looking at the issue.
I try to make a remote surveillance with sensors and EZ-Builder, and so far its going well (it is incredidble all you can do with some sensors, a camera, some leds and scripting in EZ-Builder Smile ). All I need now is an alerting system and twitter is really a easy way to do it.

#7

Oh neat! Twitter is a pretty useful service Smile It is on my schedule for today - i'll have a new release tonight Grin

#8

Was this part of the latest update? I still get this error

Code:

Start
Error on line 1: Exception of type 'System.Exception' was thrown.
Done (00:00:00.1330076)

#9

It was not - Twitter broke their twitter Tongue ..Still working on it.

#10

Hi,
I know that the problem comes from twitter itself... so I am patiently waiting... I am completely OK with that Smile

No, my question is about the thread itself. I have begin to receive emails from EZ-Robot for "Unresolved Forum Thread".
As my question is answered (I know now why twitter is not working anymore) but my issue is not resolved, should I tag this thread as resolved or not?
I wish to have the best behavior on this forum and use the new options correctly.
Thanks for the advices.