Help with Voice Recognition Disable, Enable Phrase

 
#1

Somewhere alone the upgrade line the feather in the Voice Recognition panel where we can use Disable, Enable phrases to stop and start listening stopped working. I had voice commands written there that would stop the Voice Recognition till I spoke an enable phrase. Then it would start listening again.

Could this have happened with and a result of Release 2012.10.23.00?

Thanks, Dave Schulpius

#2

Hello,

I was just checking that feature out and I am able to use the default "robot enable speech" and "robot disable speech" without any issues.

#3

We tested the feature you are having issues with and it passed. There is no issue with this feature.

Every control has a Question Mark (?) next to the Close (X) in the top right of the window. Pressing the question mark will bring help for that control. Follow the help on the control you are having issues with.

You may need to train the computer for your voice. Follow the help Smile

#4

Ok, it must be on my end then. I'll have to look it over more closely.

But,
For example here is what I have in each of the enable, disable boxes:

Enable Phrase - Wake up you bubble headed booby
Enable CMD - MP3TriggerPlayTrack( d0, 38400, 14, 3000)

Disable Phrase - Be quiet you mechanical nightmear
Disable CMD - MP3TriggerPlayTrack( d0, 38400, 13, 3000)

The robot will answer me back after I make thevoice command with his voice file that's pointed to on the MP3 Trigger. So I know he is understanding what I'm saying. He just wont stop listening and shut up.

Do my entries look OK?

Thanks, Dave Schulpius

#5

Yeah those commands look great. You may need to train the computer for your voice. Try pressing the ? button and the instructions are on the tutorial page Smile

#6

I'm at work all day today so I can't mess around with it but do you think that last perimeter is turning the listening feature back on after the 3 seconds I indicate?

#7

Oh man you're a smart guy, yes... Yes that is exactly what is happening Smile

Haha, i created the EZ-Script language, yet you know it better than me. You will have to remove the ,3000 delay from the "Disable" command.

You can use the multi-line script feature to disable the speech, then speak the mp3 trigger. And not restore the speech again.

#8

Thanks for the kind words DJ but I think I just got lucky here. Even a blind squeal will find a nut every once in a while. You've got a lot on your plate and I'm just looking at this one problem with time to think about it.

Thanks for being there for us!
Dave Schulpius