2.5 Amp Motor Controller.... Help!

 
#1

I wired up the controller per DJ's instructions. It's getting power. The little light is on but nothing happens.

Any ideas? Troubleshooting techniques?

#2

Same here. I Just got my third one yesterday but have not tried it yet. Very strange that two don't seem to work.

#3

Bookmaker did you order yours through EZ? I ordered mine through here. I assumed it would work no problems....

#4

I have the EZ-B one and one form the RobotShop. The only one that works is the little postage stamp sized red one the was originally recommended by DJ. I have burned up three of those but they all worked when I hooked them up. I have tested the new ones and they are getting a signal and the boards are getting power. It really is a mystery.

#5

Hey Sam , just double checking , did you connect your ground to the EzB and also split to directly to your power source? Also the chip that handles the business end of PWM can either take an external 5v and ground or there is the little push button , push the button and it turns the onboard 5v regulator on for the motor controllers chip and that should get you to power on. This most likely is the 5v power not being on or a grounding reference issue. I hope this fixes your problem quickly! - Josh

#6

Hey Josh,

I have this one and followed these instructions.
2.5 Amp Controller

I didn't know it needed to be grounded to the ez-board too.

These go to the battery:
1) Connect L298 VCC to your battery supply positive
2) Connect L298 GND to your battery supply negative

This is connected to pin as seen here:
3) Connect L298 +5 to a +5 pin on the EZ-B (in the diagram I used +5 from Pin D0)

4) Connect L298 IN1 to EZ-B Pin D1
5) Connect L298 IN2 to EZ-B Pin D2
6) Connect L298 IN3 to EZ-B Pin D3
7) Connect L298 IN4 to EZ-B Pin D4

Then red and black for each motor go to the appropriate motors.
8) Connect L298 OUT1 to Motor 1 (Used this one for left side)
9) Connect L298 OUT2 to Motor 2 (Used this one for right side)

If you look at the picture there is a white button. I tried pushing it, no change.

Thanks for the help

Samantha

#7

OK I was just trying to play with it again. I tried changing out the wires and I noticed when I push on the board the motors just start working.

But still when I try to use the controls nothing.

#8

Bad connection? Yes you splice ground from your controller and it also goes to the ground on.your port . They call it a ground reference. Weird that it works when u push on it. Bad.connection maybe? It shows where to ground on the board is a different place but either way.its.just a ground.

#9

OK playing with him now will try.

#10

Yea the ground from port , should also be connected to.the ground on your power source. I have 4 of these controllers but I have not had and strange issues.... Yet lol