Errors When Trying To Save To Ez-robot

 
#1

Anyone else getting this error when trying to save to the EZ-Cloud App Store ?
This just started to happening. I have been able to save in the past.

Thank you Rich

Version: 2018.05.01.00

System.NullReferenceException: Object reference not set to an instance of an object.
at EZ_Builder.UCForms.FormCameraDevice.GetConfiguration()
at EZ_Builder.UCForms.FormMaster.get_ConfigurationForm()
at EZ_Builder.FormMain.z1HXSaOIKq()
at EZ_Builder.FormMain.jGMXdLptVn()
at EZ_Builder.FormMain.SSK5Dl5wsq(Object , EventArgs )
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.RibbonItem.OnClick(EventArgs e)
at System.Windows.Forms.RibbonButton.OnClick(EventArgs e)
at System.Windows.Forms.RibbonMouseSensor.Control_MouseClick(Object sender, MouseEventArgs e)
at System.Windows.Forms.MouseEventHandler.Invoke(Object sender, MouseEventArgs e)
at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Ribbon.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

#2

Take a look at your project and find out where the value of 0 is being set to a camera setting via ControlCommand...

This is from your diagnostic log:

Quote:


6/26/2018 8:52:44 PMError Setting Camera Configuration: System.ArgumentOutOfRangeException: Value of '0' is not valid for 'Value'. 'Value' should be between 'Minimum' and 'Maximum'.
Parameter name: Value



Unfortunately i don't know where the code is being called - so you'll have to look through your project and find what ControlCommand is sending a 0 to a parameter of the camera.

#3

Thank you DJ. I will do that this evening and report back.

#4

And if you need additional help - post your project and i'll take a look. This is a super rare error, so i'd like to see what was done so i can add a more detailed response for this scenario.

#5

Ok, No problem. I will post the code that is causing the issue, how I found the bad code using your suggestion. Then I will post the corrected code that no longer contains the error. I have a post for this project it is the 18" Tall R2D2. I just have never posted any code, only pictures and how it was going. That will take a couple of days. I will put the code on this post as well as the project posting. That was it can be referenced in a couple of different ways. Where did you find the diag log ?

Rich

#6

Still trying to diagnose the error. DJ suggested that it was a ControlCommand() that was sending a zero to a camera function. I have saved the original project files to a different name to preserve the error state. I do not have any ControlCommands that I have specifically written for the camera. I pulled the Camera add on into my project at the very beginning(approx 3 months ago). Since I added the camera add on, the major thing that I have done is go from EZB connecting directly to my network at home, to using a WIFI connection. The thing that I noticed is that the video device box with the camera add was set to the wrong IP address from the network I am using now. It was set to EZB:\\10.0.0.8, which was the old address I was using with the direct connect. I am using a 192.168.1.1 WiFi address. I have taken screen shot of everything thing that has been done and the errors or non errors that followed. When I connect to my EZB I notice an error regarding the camera at the bottom screen in green. In Summary I have changed the video device box to be EZB:\\192.186.1.1 and the errors upon connection to the EZB are gone, however I get no video from the camera with it connected. I will be attaching the word document that I have created, and the project file, later on tonight when I get home from work. The project file will be the copy of the original issue. Also I am going to start a new project with just the camera function to see if there is something wrong with the camera add on. I believe that is has something to do with the fact that I changed from direct connect to WIFI. More tonight.

#7

Can you post your project here and i'll take a look? Use the Attach File option

#8
#9

It's the camera control that seems to be the issue... I downloaded your app and noticed the same issue when trying to save the project to the cloud... I also got the same error when trying to access the camera's settings... I deleted the camera control and then re-added it. It then saved to the cloud no problem...

#10

Thank you Richard. That was what I was going to try next. I was looking at other things that might have caused the camera app to get bad data in it.

DJ Attached here is the things that I tried and the errors that I still received. Please review this also.

EZBCloudApp_Errors_V2-07082018.pdf