Hbridge And Motor Speed

 
#1

I'm making my first wheeled robot using the ez robot v4. I recently connected an h-bridge to my ezb v4 without a problem. The directions were clear and concise. Operating the motors through the ez builder was easy.

My question is this, why does it appear that the motors are running slower than they can? It's a fairly slow rotation. As a test of the set up, I''m running the FingerTech "Gold Spark" 16mm Gearmotors.

Here are the motor specs:
Operating Voltage: 3V - 18.5V (>10V decreases motor life)
Nominal Voltage: 6Vdc
No Load RPM: 11530rpm
No Load Current: 0.09A
Stall Current: 1.3A
Stall Torque: 0.0461kg-cm (0.64oz-in)
Kt: 0.0352kg-cm/A (0.49oz-in/A)
Kv: 1573rpm/V
Peak Efficiency: 52%
RPM @ Peak Eff: 9100
Current @ Peak Eff: 0.34A

As a check, i connected a 9v DC 25 motor (I dont have amp info) and it's speed was similar to the more nimble gold spark motor.

Is there something I'm missing (no doubt)? Is there a different way to set-up the hbridge to increase the motors speed?

Thanks for your help.

Scott

#2

You can adjust the pwm of the hbridge in the EZ-Builder control. It’s two sliders on the side. Each slider controls left or right motor.

Ensure your hbridge is getting appropriate power and you’re golden. Have fun!

#3

Thanks DJ.

The sliders are all the way up and everything is connected properly, but the motors still appear to be running slowly. I'm running new batteries, - 6xAA - and the voltage from the battery seems fine.

Since I'm new at this, I've yet to buy any testing equipment to check the amps/voltage coming from the hbridge. It's a brand new unit that can drive two dc motors.

Any other suggestions would be helpful.

Thanks.

#4

When you move the sliders can you see the motors slow down and speed up? What brand H bridge are you using and do you have a link to it's spec sheet you can share? Are you sure you have it wired correctly?

#5

Hi Dave,

After receiving your response, I triple checked my connections and they are correct and in line with the hbridge tutorial - www.osepp.com/electronic-modules/breakout-boards/92-osepp-motor-driver-module

When I use the sliders they speed up and slow down as they are supposed to.

I'm currently using the OSEPP dual hbridge.

The website does not provide a spec sheet but does provide a schematic osepp.com/wp-content/uploads/2016/01/MOTOR-DRIVER.pdf and the following description:

Motor driver can drive a 4-wire stepper motors, or two DC motors simultaneously for your Arduino project. Ability to control motor direction and speed when used with an Arduino.

100% Arduino Compatible
L298 dual h bridge driver
Reverse motor polarity (motor direction)

** The driver comes with a 5v linear regulator supply. The 5v supply is enabled with a jumper. If your motor supply is higher than 12v it’s recommended that you remove the jumper and use an external supply. The 5V supply is enabled with a Jumper./

#6

Is there a switch that determines where the power to the motor comes from? I’m guessing it’s coming from the regulator - which would be slow.

If you connect the motor directly to the battery, does the motor spin faster than through the hbridge?

#7

HI Dj,

Hmm... my hbridge does not have a button.
User-inserted image

And, yes. It does appear that the motor spins faster connected directly to the battery than to the hbridge.

#8

Is it very noticeable speed difference? That hbridge might not be efficient and that’s the best it can do.

#9

@ggr_scott

First troubleshoot your h-bridge (alone):

User-inserted image

If you use 3 dip switches jumpers, you should have the motor on max speed.

Other variables:

1) Power

6 x AA (Alkaline batteries) = 6 x 1.5v = 9 v
6 x AA (Rechargeable batteries) = 6 x 1.2 = 7.2 v

2) H-Bridge chip L298N

Although is very easy to source and very cheap is not very efficient, the chip drops almost 2 volts. If you power the h-bridge with 7.2 v only 5.2 volts are delivered to the motors.

Check all the details and let us know your findings.

Edit 1: Correction Dip Switches i meant Jumpers

Edit 2: if you are powering the H-Bridge with more than 12 v, you will need to remove the Jumper JP1 and provide a 5V for the H-Bridge logic.

#10

Quote:

** The driver comes with a 5v linear regulator supply. The 5v supply is enabled with a jumper. If your motor supply is higher than 12v it’s recommended that you remove the jumper and use an external supply. The 5V supply is enabled with a Jumper./



Your answer is right there. Remove the jumper to take the 5v regulator out of the circuit. In your picture, the jumper is on the left, next to the green motor connector block.

Alan