Script Console Question

 
#1

I have used the Script Console over the HTTP server before for movement commands and those still work without issue
User-inserted image


However, I get an error when using ControlCommand() or even a Print() as shown below
User-inserted image

User-inserted image



I did review the tutorial and the on screen help which shows the command just like I typed it
www.ez-robot.com/Tutorials/Help.aspx?id=48

Im using vs 2017.11.13.00

Regards,
Frank

#2

It is really funny...I used the Script Console before, and I tried to look up you problem. But now it seems my script console is not working at all!

I get a weird response, saying there was an empty response when I am trying to open the console... *confused*

I can send commands using a browser without any problem, just the console is not opening, so I don't mind too much...but it is strange!


User-inserted image

#3

Other than this, you can see the example on how to use the script console on the screenshot you posted...try the examples to see how it works!


Very very strange that mine is not working...all the other menu options are working fine! Maybe the next update will fix it!


User-inserted image

*edit* I checked you syntax again and it seems to be fine...maybe you could also try to send the commands via a browser to see if it makes any difference...the syntax would kind of look like this

http://192.168.178.20//Exec?password=admin&script=ControlCommand("GlaDos", Track_Random)

I also checked your IFTTT tutorial again, and it is just kind of the same of what you did there...it should work just fine! Smile

#4

If I am using the HTTP server in a fresh project it all works fine...so maybe something is messed up in my project?

#5

@Mickey666Maus
Sorry I didn't get back to you sooner.

Its working now.. Not sure what has changed.

Thanks for your help

Regards,
Frank