Smartwebpublishing

 
#1

Why (making this a question), after an update yesterday (17-oct-2017) every time I click on any program, explorer, weather-bug, picture, whatever, I get a message telling me this file can not be found in my DVD drive?
smartwebpublishing

Is this issue the reason "save" and "save as" are non-functional? Is the EZ-Builder trying to write to my DVD? I tried to save my project to the cloud but none are there, not on my disk, not on any of my network drives, or on my user-log. Actually, nothing happens when I click either of those tabs (save or save as) and saving to the cloud didn't accomplish anything, apparently. After a few hours searching for any mention of how to save anything, I had to give up.

In an attempt to "uninstall" whatever program had caused it, the originating directory is EZ-Builder. I also found EZ-program directories in multiple locations across several users as well as workgroups and in Programs(86). Since I can't find any of the projects I've attempted to "save" or "save as" anywhere on my network, everything is already lost, should I "roll-back" and wait for this upgrade version to be fixed? Should I try to reinstall the older version? It seemed to work fine except for not being able to save anything.
User-inserted image

#2

EZ-Builder creates folders in only three (3) places...

1) C:\Program Files (x86)\EZ-Robot Inc\EZ-Builder
- Holds the main application binaries and DLL dependencies

2) [USERS FOLDER]\My Documents\EZ-Builder
- This is on a per-user basis
- This folder is created for each user that LOADS EZ-Builder. The folder WILL NOT EXIST FOR USERS WHO DO NOT LOAD EZ-Builder.
- Contains user specific folders for projects, servo profiles, logs, etc..

3) [ALL Users]\Public\Documents\EZ-Builder
- Contains shared folders for all users that include Example Projects, EZ-Bit templates and plugins

EZ-Builder will never, ever, ever look in a folder outside of those 3. There are numerous viruses which create folders based on installed programs, which may be affecting your pc. I would recommend a virus scan. Also, consider what applications or changes you've made to your PC, including other applications. If it isn't a virus, then i'd take a closer look at what other applications are installed such as SMART WEB PRINTING. And ask yourself, do you use it?!

There are no issues with EZ-Builer and your PC.

File Explorer is a Windows Component Application created by Microsoft and not part of EZ-Builder or EZ-Robot. EZ-Robot cannot assist diagnosing issues with Microsoft software.

According to your usage log, you have never saved or opened a project that wasn't an Example Project. For example, you have opened..

Quote:


10/10/2017 11:13:56 PM C:\Users\Public\Documents\EZ-Builder\Examples\SIX.ezb
10/11/2017 9:35:57 PM C:\Users\Public\Documents\EZ-Builder\AdventureBot.ezb



Even yesterday, you have successfully opened Example Projects with the latest version 2017.10.15.00

Quote:


10/17/2017 1:47:34 PM C:\Users\Public\Documents\EZ-Builder\Examples\AdventureBot - Bare.EZB
10/18/2017 1:10:05 AM Version: 2017.10.15.00
10/18/2017 1:27:47 AM C:\Users\Public\Documents\EZ-Builder\Examples\Roli - Bare.EZB



I do not know what "workgroups" are in regards to a folder - as workgroups is a microsoft term for sharing resources over a network. Folders can reside in a shared resource, but a workgroup cannot be a folder. Find out more here: http://www.tomshardware.com/faq/id-3114774/set-join-workgroup-windows.html

If you saved folders over your network, you may locate your files using FILE EXPLORER for windows first - then use EZ-Builder OPEN and navigate to the saved location. Or, double click on the EZB file on the network share and EZ-Builder will load it. By default, EZ-Builder will ALWAYS default to saving projects in your personal My Documents\EZ-Builder folder, whether that's on a network or not - that's up to your configuration.

Using google, i found many many users with issues using SMART WEB PRINTING and have it pop up. Here's one: https://answers.microsoft.com/en-us/windows/forum/windows_xp-windows_programs/smart-web-printing-text-box-appears-on-my-screen/425ea08d-5492-47c7-a7ed-f8e2f4e38672?auth=1


*Note: this question does not adhere to the terms of use for requesting assistance. requesting assistance status removed.

#3

Do not duplicate this thread topic in other threads - they will be deleted. Maintain a single conversation that you have started here. Other thread that you posted in that has been removed is here: https://www.ez-robot.com/Community/Forum/Thread?threadId=8916

Seriously, uninstall that web printing software. It's clear that the program has issues and it's entirely unrelated to ez-robot and i highly doubt you use it.

Regarding the other thread you had posted in with duplicate. That thread was regarding saving over an Example Project file - which you have done numerous times. However, there is a popup that WARNS you that if saving over an Example Project is performed, it may be lost during the next update. That is because Example Projects are always overwritten by the Microsoft Windows Installer.

Here are a few times you overwrote the Example Project and dismissed the warning..

Quote:


10/18/2017 1:33:24 AM Version: 2017.10.15.00
10/18/2017 3:53:47 AM C:\Users\Public\Documents\EZ-Builder\Examples\Roli - Bare.EZB Saved C:\Users\Public\Documents\EZ-Builder\Examples\Roli - Bare.EZB

10/11/2017 9:35:57 PM C:\Users\Public\Documents\EZ-Builder\AdventureBot.ezb Version: 2017.10.04.00
10/11/2017 9:37:27 PM C:\Users\Public\Documents\EZ-Builder\AdventureBot.ezb Saved C:\Users\Public\Documents\EZ-Builder\AdventureBot.ezb

10/17/2017 6:23:51 PM C:\Users\Public\Documents\EZ-Builder\Examples\ROLI.ezb EZ-B temperature is 24.81367440630666168C
10/17/2017 6:24:00 PM C:\Users\Public\Documents\EZ-Builder\Examples\ROLI.ezb Camera Initialized: EZB://192.168.1.1 @ 320x240
10/17/2017 6:25:37 PM C:\Users\Public\Documents\EZ-Builder\Examples\ROLI.ezb Saved C:\Users\Public\Documents\EZ-Builder\Examples\ROLI.ezb
1

#4

i looked into the EZ-Cloud. There are no usage logs of any attempts to save projects to the EZ-Cloud. The usage logs from your computer do not have any errors or even display a failed attempt. You can find out more how to save to the cloud by watching a The Robot Program episode, such as this one: http://www.ez-robot.com/Tutorials/Lesson/52

near the end of the video, we demonstrate how to save a project to the cloud. It's quite easy - and requires an internet connection.

#5

I attempted to uninstall ez. Prompt kept looking at DVD for commands. Path showed correct t. Tried to include DVD in path then prompt said file not found. Tried to reboot. Screen came up blue with prompt saying welcome to windows. Could not get past that. Bought new HD. Had to buy win10...that was the bad part. I lost my 8.1. Now formating and will be up again in 22-hours. I would like to DL the other very of EZ because it almost worked and didn't cost so much. I'd like to be able to save. I can't look at other posts now...trying to do this by phone text. I appreciate your work and your site. I plan to come back.

#6

Back in order, new drive. I expect, from what I can see with DOS command-prompt, the EZ-Builder program was in memory at exactly the wrong time when my Boot-Sector and very likely, a section of my FAT crashed. I found 16Kb-bad sectors when I formatted it and they were in cilynder-0 and 1. This explains why I wasn't able to write to my disk and also, why, when I tried to un-install ez-robot, the prompt said it was already un-installed or couldn't find the file. When I turned it off, all in memory was gone and the boot-strap-loader couldn't find a boot area. That also explains why I couldn't recover with my back-ups or restore-disks.
And, yes, I attempted to save my work in every form I could think of, including over-write the Bare because I had made a copy of it (thinking it was on my disk) to put back later. I thought you said that in one of the videos. I watched your save instructions several times. I can't see the cursor on the film when you said "save your project", so I copied it with a video editor device but zoomed in on that area of the video. That didn't work either, still couldn't see what you were clicking on. Tried to make a guess. That's why you see I tried to save so many times and didn't actually save anything. Nothing worked. When I looked for the model I'd just "save as", nothing there not even anything listed with my name. You saw that I tried to save different versions of creations using different kits, nothing worked. But I think I know why, now.
So, I'm back together and I'll try again, I've got three kits and a lot of cool ez-robot components laying here and anxious to work with it. I'm sure your program is safe. And since this post pertains to my particular machine only, I'd expect ya'll will delete this string. Thanx for your help and suggestions.
One last question, if you could, I see my CART is empty but had placed several items in there for purchase before I crashed. All of it is gone. Was that my machine that crashed or does EZ not remember the cart if you don't place the order at that time?
thanx, doron

#7

Glad everything is working again. Computers are great until they aren't.

If you didn't click through the process of buying something through the cart and it's not there now then you will have to reload the items you want and them buy them. I'm pretty sure shopping carts that have a memory of your shopping list places a file on your computer called cookies that have the items you placed there. If you have a new HD there is no way for the cart to find the old file (if EZ Robot's cart places one there at all). Smile

#8

cookie, exactly...that explains it perfectly. Thanx Dave.