Speech Recognition Dictionary Error

 
#1

Hi everybody.

It's been a while since I've posted, so before I continue I just want to say a big hello to the regulars on here such as Alan, Dave S and David C, Richard, Will, Justin, Patrick and all the others... you know who you are. And of course a big hello to DJ, Jeremie, Alan and the rest of the team. I hope that you are all doing well.

So after a year of laying dormant, I decided to blow the cobwebs away and fire up my Astromech Droid "E4-B4". So far so good but needs a little bit of fettling which leads to the point at hand to an issue I need some help with.

I fired up E4's Acer W3 tablet with the old version of EZ-Builder still installed, and also installed EZ-Builder on to my Alienware 15 (2016 version) laptop (Windows 10) with the current EZ-Builder version. The W3 is not holding its charge so I'm working with the Alienware. Couldn't connect the EZ-B v4/1 at first, but that was down to AVG antivirus so it's disabled for now and connection is all good.

The problem i can't get my head around is with the speech recognition control. I've set up Microsoft speech recognition (S/R) on the laptop, done voice training, set up the mic (type, levels etc) and checked that the mic is enabled. I've made sure that the S/R in the laptops control panel is set to "Microsoft Speech Recognizer 8.0 for Windows (English - UK), and the EZ-Builder S/R control is set to en-GB. The problem is when I save the en-GB setting on EZ-Builders S/R control. First, when I start up the project, I get the following pop up message...

Quote:

Voice recognition was not able to start. System.Exception: There is either no listening device or your operating system is not supported at EZ_Builder.UCFormSpeechRecognition.knktDlvxCWI(Object ,EventArgs



Second, when I clear the pop up and continue, select en-GB in the S/R confit menu and save it, I get the following debug error message...

Quote:

Set Dictionary Error loading phrases (custom): The Language for the grammar does not match the language of the speech recognizer.



I have tried setting the laptops speech properties to "Microsoft Speech Recognizer 8.0 for Windows (English - US) and EZ-Builder S/R control to en-US just to see if that would work, which doesn't show any debug error message, but doesn't work. I change back to en-UK, and get the same debug message as before. I have also tried restarting EZ-Builder and restarting the Laptop as well, to no avail. I've gone through the tutorials again just to familiarise myself with the control again. The actual Microsoft Speech recognition program is working on the laptop as I can open and close programs, dictate text on Notepad etc.

So does anyone have any ideas or suggestions to what I can try to get the speech recognition up and running again, maybe something like an update or installation for windows S/R or something? Any help, as always, will be appreciated.

Many thanks guys. Smile

Steve.

#2

The message states the problem. There's no listening device. That means there's no microphone. Add a microphone to your computer and you'll be up and running.

As for the dictionary - ensure you have the local installed for the desired language.

#3

DJ. He said that speech reco works on the machine, so clearly there is a microphone.

Quote:

The actual Microsoft Speech recognition program is working on the laptop as I can open and close programs, dictate text on Notepad etc.

I am thinking maybe there are multiple devices and the wrong one is set to default? Just a thought... Check the sound device properties and make sure you have a default microphone defined.

And a big WELCOME BACK Steve! You have been missed.

Alan

#4

Hi DJ. It's been a while. I hope you're keeping well. Smile

So the problem at hand. Just to confirm and as stated in my first post, there is definitely a microphone. Had there not have been one, I wouldn't have been able to do speech training, set microphone levels or use MS speech recognition control to open/close apps, dictate text, which I mentioned confirmed M/S speech recognition does work and is set up.

I also did mention that I do actually have the correct desired language installed.

Any other thoughts?

#5

Steve,

Please download the plugin:
http://www.ez-robot.com/EZ-Builder/Plugins/view/133

And check the input options to see if a device is available.

#6

Hey Alan.

Just posted at the same time, lol. I hope you're well buddy, and thanks for the warm welcome back. Smile

I'll check out the microphone settings/ properties and see what is what.

Thanks.

#7

@ptp.

Cool, I will do. Thanks mate.

#8

beep.beep.boop.boop.

good to see you back.steve G Grin

#9

Doing super good Smile good to see you back as well!

I should have expanded my answer about no input device. Meaning also verify the microphone is configured as an input device in the audio settings for windows. Some programs allow you to choose an audio input device - while others use the default. EZ-Builder does the latter.

Built in windows 8 corona has its own audio input device setting.

#10

Hello @Steve G! Great to have you back!