Award
Congratulations merne, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Camera Not Working In Client Mode

Assistance Requested

Help justkelly with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Products: (click to view product details)

EZ-Builder Control: (click to view manual page)

justkelly claims to have checked these sources:
 
#1

Attempting to get this kit up and running. I've got the base running in client mode at last, and the camera is plugged in. Both are solid green status, and EZ-Builder is connected. When I try to add the camera control, it shows the same IP as the EZB device under "Video Device". When I hit "Start", I get a continuous stream of the following two errors:

ezbv4 camera image render error: System.ArgumentException: Parameter is not valid.
at System.Drawing.Bitmap..ctor(Stream stream)
at EZ_B.Camera.E0xvOtux46(Byte[] )
at EZ_B.EZBv4Video.FGGTJPKZna(Int32 , Object )
ezbv4 camera image render error: System.Runtime.InteropServices.ExternalException (0x80004005): A generic error occurred in GDI+.
at System.Drawing.Bitmap..ctor(Stream stream)
at EZ_B.Camera.E0xvOtux46(Byte[] )
at EZ_B.EZBv4Video.FGGTJPKZna(Int32 , Object )

Can't seem to get it to work at all. Any ideas?

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Make sure the port number for you camera is is 24
Example 192.168.1.1:24

#3

In client mode your IP address must be detected by the camera control. There's a scan button just like the connection control. It's the same ip.

#4

That's what it needed: the port number. Thanks!