Congratulations Richard R, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Camera Tracking Never Stops

Assistance Requested

Help leonardo46 with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Product: (click to view product details)

EZ-Builder Controls: (click to view manual page)

leonardo46 claims to have checked these sources:

I'm going on with ezb camera experimentation.
I have experimented color or multicolor tracking . The x and y servos actually track the colored object and put it near the screen center, but they go on indefinitely moving around the screen center, with wide oscillations.
I adjusted the x and y "increment steps" in the configurazion window, reducing them to "1", but the oscillations are still there.
It seems like the servos move too much , i.e. the gain of this closed loop system is too high, making it unstable .A typical event in closed-loop systems.
I adjusted the small-large setting but it has no effect on oscillations, simply it stops tracking when not properly adjusted.
I also tried adjusting the grid lines, making the center zone narrow , hoping this could reduce the oscillation amplitude, but moving these lines seems to have no effect. I don't understand what are they for. I found no tutorial explaining in detail what's their use.
What more can I do ? Using this tracking to control my robot , I'd have a Parkinsonian robot !
Please help.

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.

Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


Have you actually clicked the check box to "use grid lines" in the camera control settings (below servo tracking check box)? By default I believe this is unchecked...


OK, Richard, this is the right way to make it work. You solved my problem.
Sometimes I sink into a glass of water !... I didn't notice the box to enable grid lines !.... Tutorials don't help much . One must click everywhere and see what happens.
Oscillations are now 2 or 3 only, then it stabilizes.
It's hard work. Continuous adjustment of grid lines, brightness, contrast, etc. is needed, depending on room light, surrounding objects, achieve good results.


Tutorial's don't help much..? *confused*

You didn't notice the box to enable grid lines because you didn't follow the tutorials goodness.


Hi, newagetomy, tutorials do help, but often don't say everything one should know ! I haven't read anywhere about grid lines .