Bing Vr Start Button

 
#1

I'm having an issue with starting Bing to listen right after EZ Builder starts. I cant start it listening by clicking the Start Recording button or starting it from an EZ Script with the start listening command.

The only way I can get the control to start recording is to go into it's settings page and click on the Save button. Then when I exit back to the front of the control everything is working right. The control will continue to work correctly until I restart EZ Builder. Then I need to do the above all over again.

Any ideas what may be going on here? I turned my Windows Defender off but nothing changed. I have no other antivirus running.

I'v attached a Youtube vid of what is happening.

Thanks!

#2

I think it may have something to do with the way the api keys are being stored after one of the recent updates, I've noticed a similar thing with the cognitive vision plugin,
- on first start of EZ builder it comes up that theres no api key
- open settings key is there
- click save and everything works fine until EZ builder is shutdown and restarted

#3

Hey Dave,

Check to make sure the api keys are set again as nick777 mentioned. I think the update that DJ pushed removed the keys due to them now being stored differently. This will happen on the cognitive recognition stuff and on API.AI also. Once this is done it should fix the issue for you for good. I noticed that they stopped working on Spock after the update to these plugins but haven't looked into it yet.

Let me know if nick777's suggestions work out for you. I think that they will.

#4

OK, thanks guys. However I installed,started using Bing and set the Key "after" the update. I'll give this a try. I'm sure if you fixed your issue like this, it will work for me.

Interesting though, I did delete the control at one time before this issue started up and reinstalled it. I remember seeing my key already inserted on the new control. After hearing your explanation I'm sure this caused it.

So, when you say "set the key" do you mean delete the old one and reenter the new and save?

Thanks again! Smile

#5

Sorry to say this did not help me.

I cleared the Key box in the control. Shut down EZ Builder and rebooted windows 10. I then went back in the Bing control and reentered my key and saved.

Everything was working again until I restarted EZ Builder. Same issue as before, Cant start the Bing control until I go into settings and click on save. *confused*

I went back in and clicked Save again bit the issue stays.

#6

I've spent some time on this problem and have not resolved anthing. I still can't get the Bing control to start recording until I go into the control, click save. Once I can see the front of the control again I can click on the start button and the control will start listening. You can see this in the video attached above.

Here's what I tried:
Deleated the EZ Builder Voice Rec control
Deleated the Bing control and reinstalled it.
Started a new project with only the Bing control installed.
Compleatly uninstalled EZ Builder and then reinstalled the latest version.
Started a new project on a new computer with only the Bing control installed.

Each time in the above stepts I deleated the KEY in the control and reset it. I then exited the project and then restarted the project (several times).

Only thing left is to some how uninstall the Bing plugin from EZ Builder and reinstall it. How do I do that? I noticed that I always have the Bing plugin in the Add To project section even after I reinstalled EZ Builder.

Help please. Any other ideas? Anyone else stillhaving this issue? *confused*

#7

Try this. open the project.
click the gear on the bing speech plugin
click OK on the window that opens up
see if you can use the plugin.

This is what I have to do to use it. I am curious if you are having the same issue.

#8

Hi David, I don't have an OK button. Just a Save and Cancel button.

#9

sorry, not at the pc. Save.

#10

Ah, Ok.

When I first start EZ Builder, the Start Recording button on the plugin control is unresponsive. I then click on the Gear Icon and after the settings page opens I click on Save. After this action has been done the control works great. However the next time I start EZ Builder after it's been shut down for the day, I have to again click on the Gear Icon, then after the settings page opens, I again have to click on Save to get it to record again. This continuously happens each time I start a new session by opening EZ Builder for the first time.