No Connection Ezb With Blackberry Priv Android 6.0.1

 
#1

Hello DJ,
i have follow problem, i have a new mobile a Blackberry Priv with Android 6.0.1.
I can connect this device with my EZB by WLan. But I can not call it in EZ-Builder Mobile there stands with Wifi SSID N / A.
What is the problem?

Thank you

#2

Connect your mobile device to the wifi access point of the ezb. Please visit the tutorials and learn section for examples using your product.

N/A means not available because there is no connection. A wifi connection to the ezb is required.

Locate the wifi of the ezb in your wifi list and connect to it.

A wifi connection between the mobile Device and ezb is necessary. Consult the manual of your device for connecting to wifi access points.

#3

Exactly that is the problem, a Wifi connection exists and in the EZ-Builder it is not displayed.
It works with another Android device, so I'm sure it is not a user error.

#4

*video deleted by owner*

#5

Hello DJ,
Can you use the videos to understand the problem?

#6

@lizpoir

To understand the issue, you have to understand Android. Android is not the same on all devices or even with all cell phone companies with the same device. Supporting Android is a difficult thing because not only do the cell phone companies make changes to Android, the phone service providers also make changes to Android. It is open source and is able to be changed by multiple parties. The only way to know that you have unmodified android is to do things that I won't go into detail here on, for fear of you bricking your phone.

I suspect that your cell phone manufacturer or cell phone service provider (probably the manufacturer) modified android to fit their needs, without consulting DJ to make sure that the EZ-Builder app would work.

I am not an Apple fanboy by any means but this is where Apple has an advantage in these types of things. The OS is the same across devices, along with using known hardware that the OS is designed to support.

Honestly, I think DJ should just support Google phones and if the other phone companies decide to change things from the Google phones that causes issues with EZ-Builder, he can simply say that its not a Google phone. Google phones run more pure Android.

I personally like Android over Apple, but this is an issue with the modifications that Blackberry has made (or security modifications that Blackberry has made) to your phone not to allow applications to control the wifi port of the phone. Because Blackberry is used primarily for business, I can see it being a security thing. I know when the company that I work for used Blackberries, they were pretty locked down by Blackberry and then by the company even more. Perhaps there is a security setting somewhere on the Blackberry to allow software to see and use wifi.

#7
#8

I was at google the other day and we were having a similar issue with a new version of android that we were using to control an ezrobot. The issue was it would say "connected", but not show connected in EZ-Builder.

This is because there "is no internet connection"

There will be a message in your notification for the android operating system (usually from swiping down at the top) which will say "no internet on this connection". You have to press a button that says MORE SETTINGS (at least on this version i saw) and say ACCEPT.

I do not know why google has done this. This will affect all access points of all devices on planet earth. This is _not_ an ez-robot specific issue. I'm certain Google will remove it eventually because of complaints like this.

However, even when i was at google, one of the android developers watched the experience on his own device.

So, you can make it work. You just have to select MORE SETTINGS or what ever it is on your device that pops up when you connect to the wifi. Your device may have even showed a popup, however your video only recorded the bottom of the screen.

#9

Hello Dj,
thank you very much, now it works.

#10

Excellent - I sent a note to my contact at google on the android communication team. I'd like to know if there's a way we can provide some permission or something in the app to bypass this condition