Running Into A Question With Iotiny Using Rotational Servos

 
#1

I have built several Adventure Bots and have not had any issues, but when I tried to build a custom 2 WD robot using IoTiny I've run into a strange problem.

Using the same "continuous rotation servo with Wheel" set from my Adventure Bot I found that they worked for about a minute before refusing to run any more.

I thought it might be just a coincidence, so I took another working set and first tried that with a EZ-B v4 controller in a Power Shell with the same "LiPo Robot battery" (after a full recharge) that I was using on IoTiny ... and those wheels worked fine

But, when I connected the wheels back to the IoTiny, the servos worked for a little while and then stopped working!

What's worse, is that I reconnected the servos back into the Adventure Bot and NONE of then worked anymore.

Any ideas?

Frank

#2

The IoTiny is a smaller ezb. There are no differences. The situation you experienced was coincidental to something ubrrlated to the IoTiny. Answer these please

how was it wired?

Was it mounted on a conductive surface?

What other devices were connected to it?

What is the weight difference of the custom robot vs adventurebot?

Where the continuous rotation servos the older discontinued plastic gear ones?

#3

@DJ,
Sorry about the slow response, as I was waiting for my 2nd IoTiny and new servos to confirm the issue

here is a pic of my testbed
User-inserted image

No load on servos, IoTiny temporarily mounted on a Power Shell with 3M Command tape and using AdventureBot Bare example. The servos have metal gears. Nothing else is connected. The firmware was left as shipped as its later than the version in the current release package

The test with the 2nd IoTiny and servos had the same result... please see videos below





I tested an HDD lever arm servo and that works fine.

I could ship you the IoTinys and servos if that would help

Regards,
Frank

#4

There's no need to ship us anything. The IoTiny isn't a problem. It is a smaller ezb. It's identical in that fashion. As you can see from the videos, I use IoTiny in lots of robots.

Regarding the servos, I'm guessing power or short in the connector? The video zooms in onto the servo and loses focus of the IoTiny, so I can't see the status led.

Does the IoTiny lose connection?

Also, you state the servos no longer work at all after they're used on the IoTiny? To clarify, the servos are broken after the IoTiny?

Show us your battery and power configuration.

What's on the bottom of the IoTiny?

#5

@Frank... I downloaded the Adventure Bot project and duplicated your setup... I had no issues with using an iOTiny... Mine worked perfectly... I even tried a second ioTiny and it also had no issues...

***EDIT*** FYI I used a 7.4V Li-Ion battery in my test...

#6

I think the question about your power source becomes critical for further troubleshooting. Note: the picture of your test bed which may have answered that question apparently didn't upload. It is a dead link.

Alan

#7

Testbed picture:
User-inserted image

My bet is on the power source being the problem.

#8

@faengelm

What commands/controls where you using to test the 360° Servos? Were you using the Adventurebot program with the analog joystick?

Are the servos the new metal gear 360° Servos? (Just use a phillips screwdriver to remove screw on the wheel to see if the output gear is metal or plastic)

*Edit I just noticed you mentioned that they are metal gears already, sorry about that

#9

First, I want to thank everyone for the great responses.. I'm impressed with the level of support and I'll try to answer all the questions. I know this is a very unusual problem and really can't believe it myself.

I have improved the test bed to make it clearer, just a 2*4 with the gear connected with 3M Command strips

@DJ
I don't think is a problem with the power connector as I'm using the same battery and connector with the the EZB-v4 tests

The servos which worked on the V4 no longer work on the same V4 aftera test run on the IoTiny

The battery is the standard EZB battery

@Richard_R
Thanks for taking the time to duplicate my setup. I am using the 7.4 Li-Po battery

@thetechguru
The new videos below will show the layout

@PTP,
I'm using the same power setup on the V4 and IoTiny

@Jeremie
I'm just using the standard Movement Panel that is part of the AdventureBot bare example

Here all the new videos. The servos are first tested on the v4 setup, then I replace the v4 for the IoTiny and use the same battery and cable with connector





My new test bed only tests one servo at a time as I was ruining too many of them

Regards,
Frank

#10

@faengelm,

Can you post your project.

And the actions to replicate the issue.