Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Assistance Requested

Help slickfix with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Product: (click to view product details)

EZ-Builder Control: (click to view manual page)

slickfix claims to have checked these sources:
 
#1

When I use the mobile Ez builder app and use Blocky , I get and Error message when I try to use the Say Ezb command.

Example: SayEZB "Hello World"

Code SayEZB("Hello World")

I get the error message >Error on line 1: Attempt to invoke virtual method 'java.lang.Objectjava.util.HashMap.get(java.lang.Object)' on a null object reference

When I use this in the PC version of Ez Builder it works fine.

Is this a bug in the mobile version? Not yet implented yet?

Thanks,

Eric

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Not all devices support that function. Yours does not Smile

#3

Thanks DJ,

In Devices do you mean my Galaxy s6 phone, or all android devices?

Thanks Again,

Eric

*confused*

#4

Broke with Android 6.01. Not sure if it is working again in Android 7 or if it is still broken. I rarely use the mobile app and haven't tried since my phone got upgraded.


See: https://www.ez-robot.com/Community/Forum/Thread?threadId=10085


(I do now have Android 7 so can test at some point, but am too busy this afternoon).

Alan

#5

Android devices. My Samsung note and tablet works. That's all I can verify with Smile

#6

What Android version are your devices DJ? It worked on my Nexus 7 and Galaxy S6 until they updated from Android 5 to Android 6.

Alan

#7

Android 6 (API 23) - the mobile app is always compiled against the latest android sdk

#8

Strange stuff. This definitely worked on the Nexus 7 and Galaxy S6 (which I no longer have. On an S8 Android 7 now. I'll try to test this weekend, also still have the S7 which is also on Android 7 now) prior to their 6.01 upgrades, so it isn't a hardware issue.. The Nexus is pure Android, so we can't blame it on Samsung's changes to Android.

Maybe I should send you my S7. I'll be in Banff this summer, maybe I can drop it in the mail when there so I don't need to deal with international shipping and customs declarations and such (still haven't convinced my wife to come visit EZR, but maybe if we have a really rainy day).

Alan

#9

I won't be in calgary until september. Although, i'm sure everyone at the office would love to see you!

I'll poke into the API and see if there's any docs about certain versions deprecating the call.

#10

Got it - there's a deprecated xamarin bind to the android native function which is expired. I guess some devices still support it and others don't. I'm checking for the API version and using the new function, respectively.

It's uploaded now and will be online in a few hours or by tomorrow at the latest. Android updates pretty quick