Shoulder Servo Of Jd Robot Not Working

 
#1

Hi,
I just bought a new JD Revolution robot last weekend for my kids. I bought it when I was in Australia last week, but we live in New Zealand.
After going through the tutorials with my daughter we constructed our robot. When we first turned it on and connected to the EZ Builder program everything was looking good (although the wires coming out of the body didn't have the L and R on them like the tutorial mentioned so we had to guess). We started the servo calibration and just as we were doing this the right should started to go a bit haywire, kept on twitching and was rotated by between 45 and 90 degrees from where it originally was when we started calibration (nicely upright).
We kept on calibration with it twitching away thinking it may come right after we finish. We started getting JD to do a wave (which is the left arm) and it worked OK. But when we started to do some of the other moves the arms would sometimes clash, and I could see that the right arm wasn't moving at the shoulder.
I looked through some of the tutorials and found how to test individual servos, I tested the left servo and it moved fine, when I tested the right servo did nothing at all.
Is this covered by warranty? How do I go about getting this fixed?
Thanks very much,
Tim

#2

Hi Tim

Yup! Sounds like a bad servo for sure. Use the Contact Us form and submit this thread URL for reference. It'll be taken care of to get your JD up and running Grin

As for the servo labels, the first generation JD, which is what you have, doesn't have labels on the servos. The current JD version use the HDD servos, which are explained in detail here: http://www.ez-robot.com/Tutorials/Lesson/48?courseId=1

If you wish to upgrade to the latest servos, feel free to inquire in the Contact Us message about an upgrade package. It's not necessary, the newer servos are merely quieter. You can verify the servo version on your JD if they read HD or HDD. HDD are the newest ones. HD are the previous version.

There is a great tutorial that you might have missed to identify the servos from the body, even though you seem to have taken care of that, well done!

For future reference it's right here: http://www.ez-robot.com/Tutorials/Lesson/84?courseId=1

It's mentioned in the build lesson here:
User-inserted image

#3

Thanks. Have received my warranty servo, and I replaced all the other servos too, all working now and my daughter is having a great time discovering what JD can do!

#4

that's great to hear! Enjoy JD, sounds like he has a great home! Grin

Here's a list of Activities she can start learning to program with: http://www.ez-robot.com/Tutorials/Lesson/-1?courseId=1&sectionId=164