Development Of Autonomous Navigation Robot

 
#1

Hello everyone, first of all I want to thank everyone in the community for providing essential information regarding the EZ-Robot. The video below is one of the successful testing of Autonomous Navigation Robot, using the Roli Rover Platform integrating both EZ-Builder Software and Roborealm. This was my Final Year Project and I have just finished demo-ing the project last week. Maybe after the report writing, I will release a tutorial of how I did it? Just to give back to the community. Of course, I am open to suggestions and ideas. But thank you all again.

Regards,
Recon

#2

@recon
This is really great.

I'm very interested in seeeing your tutorial as I had problems getting RoboRealm to make thee map


Regards,
Frank

#3

Well done!

Love that Rover, moves very well, smooth and fast good stuff.

#4

@faengelm Hi thanks very much, I will do me best to upload the tutorial as soon as possible. Do you mind elaborate more on the problem itself?Might be something I have encountered before.

@NEWAGETOMY Thank you. Took me a long time to figure things out as well. Winky Winky

Regards,
Recon

#5

Great job ! Congratz !

#6

I did the same thing using a Roomba and Roborealm (with avm navigator)... I even think I have a video of mine out there somewhere too... Works ok as long as you don't move furniture or change the lighting... @DJ's IPS system should do so much better. Can't wait for it to come out...

#7

@PhG Thanks very much, appreciate it.
@Richard R I did actually seen that video, and it gave me the confidence that it is in fact do-able. Thank you for your contributions. Winky Winky

#8

@Richard-R

I found your post.... Smile

https://www.ez-robot.com/Community/Forum/posts.aspx?threadId=8381

@Recon,
Thanks for your offer of help. I will did up my notes on my issues

Regards,
Frank

#9

@Recon
Thanks for your offer of help.

I now have the Marker Mode making a pretty accurate map, but am having problems getting the EZB robot to follow the map in the Navigation Mode.

User-inserted image

Which EZBRobot variables are you using in your EZB scripts for motor control?

I have been trying $RR_NV_L_MOTOR and $RR_NV_R_MOTOR without success

Can you share you scripts for the Movement Panel?

Regards,
Frank

#10

@faengelm
Hi there, basically you have to set up the H-Bridge PWM Movement Panel and write a script for the movement of the robot, called it a AVM Navigator. You wouldn't be needing the $RR_NV_L_MOTOR and $RR_NV_R_MOTOR variables. So it would be something like this,

:loopForever

if($RR_NV_FORWARD) //reading forward button

SetSpeed (96,96) //set speed
Forward() //Forward Movement

elseif ($RV_NV_LEFT)

SetSpeed(96)
Left()

and so on for other movements..

Basically with the script above you should be able to manually control your robot in Marker Mode and in Navigation by map it will virtually pressed the key for autonomous navigation. Of course, TCP connections have to be enabled to sent the movement signals as well. Hope that helps you.

Cheers.
Recon Winky Winky