Cameramotiontracking Not Working In Mobile App

 
#1

Hi All,

I'm trying to get movement tracking to work in the mobile app.

When I press 'Connect' the app connects and I can see the camera feed

I have a run script button with the following code at the start of the script

Code:


ControlCommand("Camera", CameraMotionTrackingEnable)
sleep(1000)

*Rest of script*



When I press the script button, it goes green to say it's running but nothing happens.
When I run the exact same script from EZ-Builder desktop everything works fine *confused*

If I put the ControlCommand("Camera", CameraStart) at the start of the script then the script won't even run, so I'm assuming that's not needed.

Am I missing something?

Thanks

#2

Motion tracking is not supported on mobile: http://www.ez-robot.com/Tutorials/Help.aspx?id=196

Use the question mark (?) on every control to access the manual page for that control.

User-inserted image

*note: Removed requiring assistance due to incorrect information provided by OP, which affects the support learning AI. Answered "yes" to reading the manual or tutorial, but OP did not.

#3

I did read the tutorial. It says

Controls marked with an asterisk(*) may not have standalone user interfaces and support is limited to the mobile interface builder. For example, the Camera view may be added to a mobile interface, yet it does not have a standalone view. The camera control features are controlled by ControlCommand() via ez-script


From that I read it as. The motion control may not work so you will need to activate it with a script. Which I did.

A simple "no it's not supported" would have been all that was needed, instead of assuming I didn't read the tutorials. *mad*