Message Recieved When Trying To Add

 
#1

What is wrong? Never seen this before... upgraded to latest version. Using new IOTiny...

Error when selecting any script control...


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Parameter is not valid.
at System.Drawing.Image.get_RawFormat()
at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y, Int32 width, Int32 height)
at System.Drawing.Graphics.DrawImage(Image image, Rectangle rect)
at System.Windows.Forms.PictureBox.OnPaint(PaintEventArgs pe)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
EZ-Builder
Assembly Version: 2015.8.9.0
Win32 Version: 2017.03.06.00
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/EZ-Builder.exe
----------------------------------------
PresentationCore
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/PresentationCore/v4.0_4.0.0.0__31bf3856ad364e35/PresentationCore.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
EZ_B
Assembly Version: 2015.7.28.0
Win32 Version: 2017.03.06.00
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/EZ_B.DLL
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Speech
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Speech/v4.0_4.0.0.0__31bf3856ad364e35/System.Speech.dll
----------------------------------------
EZ-RibbonMenu
Assembly Version: 2015.7.3.0
Win32 Version: 2016.12.19.0
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/EZ-RibbonMenu.DLL
----------------------------------------
Alsing.SyntaxBox
Assembly Version: 2015.5.15.0
Win32 Version: 2016.12.19.00
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/Alsing.SyntaxBox.DLL
----------------------------------------
WindowsBase
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
System.Web
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Web/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Web.dll
----------------------------------------
CefSharp.Core
Assembly Version: 53.0.1.0
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/CefSharp.Core.DLL
----------------------------------------
CefSharp
Assembly Version: 53.0.1.0
Win32 Version: 53.0.1.0
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/CefSharp.DLL
----------------------------------------
CefSharp.WinForms
Assembly Version: 53.0.1.0
Win32 Version: 53.0.1.0
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/CefSharp.WinForms.DLL
----------------------------------------
FFMPEG
Assembly Version: 2013.8.13.0
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot%20Inc/EZ-Builder/FFMPEG.DLL
----------------------------------------
System.Xaml
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xaml/v4.0_4.0.0.0__b77a5c561934e089/System.Xaml.dll
----------------------------------------
Microsoft.GeneratedCode
Assembly Version: 1.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Web.Services
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Web.Services/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll
----------------------------------------
Microsoft.GeneratedCode
Assembly Version: 1.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
Assembly Version: 1.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.ServiceModel
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.ServiceModel/v4.0_4.0.0.0__b77a5c561934e089/System.ServiceModel.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:





When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

IO Tiny connection details....

EZB 0:
EZB 1:
EZB 2:
EZB 3:
EZB 4:
Screen Resolution: 1366x768 (96x96 dpi)
Version: 2017.03.06.00
Attempting connection on 10.0.0.224:23
Connected to 10.0.0.224:23
Reports EZB v4 OS IoTiny
EZ-B v4 IoTiny ID: 222-222-222-222-222-222-222-222-222-222-222-222
EZ-B v4 IoTiny has temporarily configured the audio pre-buffer to 5,000 Bytes for this session. (Options -> Preferences -> Audio)
Setting battery monitor voltage: 7
Setting battery protection: True
Setting i2c rate: 100000
EZ-B voltage is 9.285291336
EZ-B temperature is 24.76099144578371760C
Connected

#2

awesome to see the AI answer the question correctly before any of us Grin nice work support robot. guess you can mark this as resolved and give credit to the robot

#3

DJ I have done the following:
1) scanned for virus - none.
2) Re-installed .Net
3) Uninstalled and reinstalled EZ builder
4) Checked for low memory issues - none (6MB ram, using only about 1.5 while running).

Problem is still present. I have ran on the same PC for several years and had no problem.

Problem not noticed before upgrading to your March 6 update. I last updated on 1/31/2017 with the build at that time.

Any further assistance would be helpful.

Thanks.

#4

DJ,
Problem went away with 3/20/2017 update.